Tenon Intersystems Please see text links at bottom of page for navigation Please see text links at bottom of page for navigation
Please see text links at bottom of page for navigation Please see text links at bottom of page for navigation
Please see text links at bottom of page for navigation
Google
Search this site:



iTools 7 : Security : How does apple's 2004-12-02 security update affect me? back to FAQ
Question:How does apple's security update for HFS+ with apache affect me?
Answer:If you are running iTools 7.3.3 or older you will need to make the following change to your httpd.conf file:

iTools 7 uses Apple's Apache for 1.3, however if you are running 1.3 and if the Apple security update installer replaced the link to our config file with their default config file you may need to make these changes to your httpd-1.3.conf configuration file and re-link it to /etc/httpd/httpd.conf.

If you are running Apache 2 (the default) with iTools 7 then you will need to make the following change to your httpd.conf file.

In the file "/Library/Tenon/WebServer/Configuration/httpd.conf", replace:
{bbc_code}:

<Files ~ "^.ht">
Order allow,deny
Deny from all
</Files>




with:

{bbc_code}:

<Files ~ "^.([Hh][Tt]|[Dd][Ss]_[Ss])">
Order allow,deny
Deny from all
Satisfy All
</Files>
<Files "rsrc">
Order allow,deny
Deny from all
Satisfy All
</Files>
<DirectoryMatch ".*..namedfork">
Order allow,deny
Deny from all
Satisfy All
</DirectoryMatch>


last updated 16.12.2004
Powered by FAQEngine V4.07.4 ©2001-2005 Bösch EDV-Consulting